Skip to main content

Cisco IOS EIGRP Protocol

Network Topology

image.png

Router0 Configuration Commands

Router0>enable
Router0#configure terminal
Router0(config)#interface serial 0/0/0
Router0(config-if)#ip address 172.16.1.1 255.255.255.248
Router0(config-if)#no shutdown
Router0(config-if)#interface gigabitEthernet 0/0
Router0(config-if)#ip address 192.168.10.1 255.255.255.0
Router0(config-if)#no shutdown
Router0(config-if)#exit
Router0(config)#router eigrp 100
Router0(config-router)#network 192.168.10.0 0.0.0.0
Router0(config-router)#network 172.16.1.0 0.0.0.0
Router0(config-router)#no auto-summary
Router0(config-router)#end

Router1 Configuration Commands

Router1>enable
Router1#configure terminal
Router1(config)#interface serial 0/0/0
Router1(config-if)#ip address 172.16.1.2 255.255.255.248
Router1(config-if)#no shutdown
Router1(config-if)#interface gigabitEthernet 0/0
Router1(config-if)#ip address 192.168.20.1 255.255.255.0
Router1(config-if)#no shutdown
Router1(config-if)#exit
Router1(config)#router eigrp 100
Router1(config-router)#network 192.168.20.0 0.0.0.0
Router1(config-router)#network 172.16.1.0 0.0.0.0
Router0(config-router)#no auto-summary
Router1(config-router)#end

Comments on a Couple of Configuration Items

A couple of notes about the configurations.  First, the network commands show a wildcard of 0.0.0.0, this denotes an exact match for the specific IP on the interfaces.  I could have also made the command be for a subnet with network 192.168.10.0 0.0.0.255  It was simply a preference on my part for this configuration.

Second, the command no auto-summary.  EIGRP is a routing protocol that supports auto summarization.  This isn't very intuitive to understand. Auto summarization in EIGRP means that it will automatically advertise the classful A, B, or C subnet if it is not told otherwise.  Let's take a look at another network topology to demonstrate the auto-summary effect.

image.png

In the above example there are three routers configured for eigrp.  In the initial setup Router0 and Router2 have auto-summary on for EIGRP. All three networks 192.168.2.0, 172.16.1.0, and 1.1.1.0 are configured in the EIGRP router for Router0.

image.png

Similarly, Router 2 has EIGRP configured and 1.3.3.0 and 192.168.20.0 are configured.  Also, auto-summary has been explicitely turned on.

image.png

Router1 is pretty vanilla with EIGRP configured and advertising the 192.168.10.0 and 192.168.20.0 networks.  No auto-summary is on for Router1.  The interesting thing is taking a look at the routing tables of each of the routers to see what auto-summary does in this scenario. And how it will break the routing.  Let's look at Router0 first.

image.png

The 1.1.1.0 /24 network has been summarized the classful A network of 1.0.0.0 /8. Similarly, the 172.16.1.0 /24 has been summarized to the classful B network of 172.16.0.0 /16.  This isn't necessary bad when you just look at it from Router0's perspective but hold that thought until we take a closer look at Router1 in a moment.  One last note for Router0, the network 192.168.10.0 /24 is as expected becasue it is already a class C network.

No let's look at Router2 and then we will get to Router1.

image.png

Now, you can already start to see the problem, Router2 is advertising a summarized classful A for 1.0.0.0 /8 just as Router0 was.  And what does that do to Router1, confuses the heck out of its routing table, that's what! Let's look.

image.png

So, now Router1 is advertising that 1.0.0.0 /8, which is the summarized subnet for both 1.1.1.0 and 1.3.3.0 is reachable through both the other routers.  This is what unchecked auto-summary can do to EIGRP if you are not careful.  The fix is to turn off auto-summary in Router0 and Router1. And problem resolved. Take a look at Router1, the one that was so confused before we turned off auto-summary, it has the correct routes now.

image.png

Back to the EIGRP Configuration

Verify the configuration

Router0#show ip route

image.png

Router0#show ip eigrp neighbors

image.png

Router0#show ip eigrp topology

image.png

Router0#show ip eigrp interfaces

image.png

Router0#show ip eigrp traffic

image.png

Ping and Tracert Tests

image.png

Cisco Packet Tracer Files

net16 eigrp.pkt

net17 eigrp auto-summary.pkt